-
Monitoring
Our Community Server Box is currently being transfered to a more suitable location for our community, this should hopefully combat any desync issues you notice.
04:48, Nov 10 UTC
-
Resolved
Boxed has been fully transfered, servers are now operational.
06:31, Nov 10 UTC
Back to current status